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How to set up a local root folder and site structure 
The first thing to do when creating a new website with Adobe Dreamweaver CS3 is to define a site and identify a 
root folder where you will save all files, images, and other elements for the web pages. 

Setting up a local root folder 

1. Create a folder on your computer to serve as the main 
folder for your website. Give the folder a name that 
identifies the website.  

 This folder is called the local root folder. 

 Note: When creating a root folder for a site on your 
computer, it is highly recommended that you place it at 
the top level of your hard drive. For example, C:\my-site 
(Windows) or Macintosh HD: my-site (Mac OS). 

2. Start Dreamweaver. 

3. From the menu bar, select Site > Manage Sites. 

 The Manage Sites dialog box opens. 

4. Click New and select Site from the pop-up menu that 
appears. 

 The Site Definition dialog box opens (Figure 1). Make 
sure the Basic tab is selected. 

5. Delete the temporary name, Unnamed Site 1. Enter a 
new name for the site. Leave the URL field blank for 
now (or enter a URL given by your instructor). 

 Click Next. 

6. Make sure No, I Do Not Want To Use A Server 
Technology is selected (Figure 2), and click Next. 

 

Figure 1 Site Definition dialog box (Basic) 

 

Figure 2 Site Definition dialog box, page 2 
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7. Make sure Edit Local Copies On My Machine, Then 
Upload To Server When Ready (Recommended) is 
selected (Figure 3). 

8. Click the Folder icon to the right of Where On Your 
Computer Do You Want To Store Your Files? 

 The Choose Local Root Folder For Site dialog box 
opens (Figure 4). 

9. Locate and select the root folder you created for your 
site. Click Open and then Select (Windows), or click 
Choose (Mac OS). 

10. Click Next. 

11. Select None in the How Do You Connect To Your 
Remote Server? pop-up menu (Figure 5). Click Next. 

 

Figure 3 Site Definition dialog box, page 3 

 

 
Figure 4 Choose Local Root Folder For Site 
dialog box 

 

Figure 5 Site Definition dialog box, page 4 
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 You are presented with a summary of your settings 
(Figure 6). 

12. Click Done. 

 Your local root folder is defined. 

13. Click Done in the Manage Sites dialog box. 

 On the right side of the Dreamweaver window, the Files 
panel displays the folders and files of your site 
(Figure 7). In Windows, the Files panel is one of the 
docked panels at the right side of the window. You can 
leave this panel open as you work. In Mac OS, the left 
side of the Site panel shows a map of the site as you 
create it. If the panel is not docked, you may want to 
close it. 

 

Figure 6 Site Definition dialog box, page 6 

 

 
Figure 7 Files panel 

Modifying site information 
You can change settings for your site at any time. 

1. Select Site > Manage Sites from the menu bar. 

 The Manage Sites dialog box opens (Figure 8). 

2. Select the site name and click Edit. 

 The Site Definition dialog box opens. 

3. Change any of your original settings as desired. 

 

 
Figure 8 Manage Sites dialog box 
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The Dreamweaver interface 
Student name: _________________________________________________ Date:________________________ 

The most commonly used parts of the Adobe Dreamweaver CS3 interface are the Document window, the Insert bar, 
the panels, and the Property inspector. In the figure below, label the Document window, the Insert bar, the panels, 
and the Property inspector. 
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The Insert bar contains buttons for inserting various types of objects, such as images and tables, into a document 
(web page). The Insert bar contains several categories, such as Common and Layout. 

The Common category contains buttons for inserting the most commonly used objects. 

Identify the buttons on the Common category in the Insert bar. 

 

 

 

 
 

 

 

 

 

 

 

 

 

 

Identify the buttons on the Layout category in the Insert bar. 
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The Property inspector enables you to view and change a variety of properties for the currently selected object or 
text. 

Describe the Property inspector. 
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The Dreamweaver interface 
You can access Adobe Dreamweaver CS3 tools, commands, and features by using menus or by selecting options 
from one of the Insert bars or from Dreamweaver panels. The most commonly used areas of the Dreamweaver 
interface (Figure 1) are the Document window, the Insert bar, the panels, and the Property inspector. 

The Document window displays the current document as you create and edit it. The Insert bar contains buttons for 
creating and inserting objects such as images, tables, layers, and frames you might want to add to your web pages. 
The Property inspector displays properties for the selected object or text and lets you modify those properties. The 
right side of the window, by default, displays panels you can expand or collapse as you need them. 

One of the most frequently used panels is the Files panel. This panel displays the organization of your site and lets 
you open files for editing, publish files to a server, or delete files. 

Another frequently used panel is the Assets panel. This panel provides two ways to view site assets. Site assets are 
elements used in a site, such as images, colors, or movies. 

The Assets panel provides two ways to view assets: 

• The Site list shows all of the assets in your site. 

• The Favorites list shows only the assets you’ve chosen to include in the Favorites list. 

The Document window and panels 
You can add and manipulate text, images, menus, tables, and other elements in the Document window, and it will 
display an approximate representation of your web page. 

 
 
 

Figure 1 Dreamweaver interface 
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The Insert Bar 
The Insert bar contains buttons for inserting various types of objects, such as images and tables, into a document. 
The Insert bar contains several categories, such as Common and Layout. The Common category in the Insert bar 
(Figure 2) contains buttons for inserting the most commonly used objects. 

Common category in the Insert bar 
 
 

 
 
 

Figure 2 Common category in the Insert bar 

Hyperlink: Insert a hypertext link. 

Email Link: Insert a link to an e-mail address. 

Named Anchor: Insert a link to a specific location on a page. 

Table: Insert a table. 

Images: Insert an image. 

Media: Insert media objects, such as Flash, Shockwave, Applets, and ActiveX. 

Date: Insert the current date, with an option for automatic updating when you save the document. 

Comment: Insert a comment, which will not be displayed on your web page. 

Head: Insert keywords, meta tags, page descriptions and other document data that is kept in the page’s head tag. 

Templates: Make a template based on the current document. 

Tag Chooser: Insert an HTML tag. 

Hyperlink Named Anchor Images Date 

Email Link Media Comment Templates 

Tag Chooser 

Table 

Head 
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Layout category in the Insert bar 

From the Layout category in the Insert bar (Figure 3), you can insert tables and choose between two modes. 
Standard mode displays tables as a grid of lines. Expanded Tables mode adds cell padding and spacing to tables and 
increases table borders to make editing easier.  
 
 

 
 
 
 

Figure 3 Layout category in the Insert bar 

Insert Div Tag: Insert a div tag to create a content block. 

Draw AP Div: Insert an absolutely-positioned div tag to hold content at a specific location on the page. 

Spry Menu Bar: Insert a set of navigational menu buttons that display submenus when a site visitor hovers over one 
of the buttons. 

Spry Tabbed Panels: Insert tabs that a site visitor can click to reveal hidden content. 

Spry Accordion: Insert a set of collapsible panels that can store a large amount of content in a compact space. 

Spry Collapsible Panel: Insert a panel that can hide or reveal a large amount of content when a site visitor clicks the 
tab of the panel.. 

Table: Insert a table. 

Insert Row Above: Insert a row above the current row in a table. 

Insert Row Below: Insert a row below the current row. 

Insert Column to the Left: Insert a column to the left of the current column. 

Insert Column to the Right: Insert a column to the right of the current column. 

IFrame: Insert a content block in which the browser displays a separate HTML document. 

Frames: Insert a frame. 

Layout Table: Draw a whole table with cells to hold information or objects (only available in Layout mode). 

Draw Layout Cell: Draw individual cells in a table (only available in Layout mode). 

Table Draw AP Div  IFrame 

Insert Div Tag Insert Columns and Rows Frames Spry Widgets 
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The Property inspector 
In the Property inspector, you can view and change a variety of properties for the currently selected object or text. 
Each kind of object has different properties. Figure 4 shows the Property inspector for a selected table. It displays 
column and row attributes, cell colors, and border colors. You can change cell padding (the amount of space 
between the cell content and cell walls) and cell spacing (the amount of spacing between table cells) as well. When 
you select text, you can alter font, size, color, and alignment in the Property inspector. 

 
Figure 4 Property inspector 
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Working with text and images 
Text and images are the basic elements of almost every website. You add text just as you would in a word 
processing program, and you add images by inserting them from an existing file. 

Adding text to a document 
Adding and modifying text works much like a word processing program. You add text by using the keyboard or by 
pasting from another document. You modify text by using the Property inspector. The Property inspector features 
icons like those found in word processing programs, such as Bold, Italic, Left Alignment, and Right Alignment. 

To add and modify text: 

1. Open a document in Adobe Dreamweaver CS3. 

2. Position the insertion point where you want to add text. 

3. Type desired text or paste text copied in another 
application. 

 Once you add text, you can change its properties in the 
text Property inspector (Figure 1). 

 Make sure the Property inspector is open. In Windows, 
it is docked at the bottom of the screen. If the Property 
inspector is not open, select Window > Properties. 

4. Select the text to be modified. 

5. In the Property inspector, change the size of the text by 
using the Size pop-up menu. 

 You can also apply a paragraph or heading format, apply 
bold or italic formatting, change text alignment, or 
change text indentation. 

 Note: You can apply different formats to separate text 
elements on a single page. 

Figure 1 Text Property inspector 
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Using font combinations 
In formatting text, a good practice is to assign a font combination instead of a single font. This ensures that most 
page visitors will view page text the same way. 

Font combinations determine how a browser displays text on a web page. A browser uses the first font in the 
combination that is installed in the visitor’s system. If none of the fonts in the combination is installed, the browser 
displays the text as specified by the visitor’s browser preferences. The fonts specified in Dreamweaver’s default font 
combinations are generally available in both Mac OS and Windows. 

Font combinations are available in the text Property inspector. 

To apply a font combination: 

1. Select the text to be formatted. 

 Make sure the Property inspector is open. In Windows, 
it is docked at the bottom of the screen. If the Property 
inspector is not open, select Window > Properties. 

2. In the Property inspector, apply a font combination, 
using the Font pop-up menu (Figure 2). 

 Note: You can apply different font combinations to 
separate text elements on a single page. 

Figure 2 Text Property inspector with font 
selected 
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Adding images 
You can insert any image into a web page, as long as it is accessible to Dreamweaver and in a web format. Most 
images in web pages are either GIFs or JPEGs. 

To add an image: 

1. Open a document in Dreamweaver . 

2. Make sure the document is saved in your site’s local 
folder. 

3. Position the insertion point where you want to add an 
image. 

4. Select Insert > Image. 

 The Select Image Source dialog box opens (Figure 3). 

5. Browse to the folder with the desired image. 

6. Select the desired image. 

 A preview of the image appears in the right side of the 
dialog box. 

7. Click OK. 

 If the image is not in your site folder, Dreamweaver asks 
if you want to copy the file there (Figure 4). 

8. Click Yes.  

 The Copy File As dialog box opens. 

9. Browse to the folder where you want to copy the file. 
Then click Save. 

 The Image Tag Accessibility Attributes dialog box 
opens (Figure 5). This dialog box lets you add a 
description to the image so that screen readers can 
interpret it. 

10. Enter a brief description. You can also provide a link to 
a file with a longer description. 

11. Click OK. 

 The image is added to your document. 

Figure 3 Select Image Source dialog box 
 

 
Figure 4 File outside of root folder warning 
message 
 

 
Figure 5 Image Tag Accessibility Attributes 
dialog box 
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Resizing images 
You can resize an image by clicking on it and dragging selection handles. 

Note: Changing the width or height of your image in Dreamweaver can reduce the image quality. It is better practice 
to resize an image in an image-edited program such as Adobe Fireworks CS3 before importing it into Dreamweaver.  

To resize an image in Dreamweaver: 

1. Select the image. 

 Selection handles appear on the right and bottom edges 
of the image (Figure 6). 

2. Do one of the following. 

• To resize the image horizontally, drag the selection 
handle in the right. 

• To resize the image vertically, drag the selection 
handle in the bottom. 

• To resize in both directions at the same time, drag 
the selection handle at the lower right corner. To 
retain the relative proportion of height and width, 
hold down Shift as you drag. 

 
Figure 6 Image with selection handles 
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How to create a basic table 
In Adobe Dreamweaver CS3, you can add text and images to table cells the same way you add text and images to a 
page. After you create a table, you can easily modify both its appearance and its structure. 

Inserting a table on a page 
You can insert a table anywhere on a page, including within another table. You can quickly insert a standard table 
with three rows and three columns, or you can modify options to insert a custom table. 

When you insert a table, a good idea is to set a header property for a row or column if you will use that row or 
column to provide labels for the information in the table. A header makes the table more accessible to people with 
visual impairments, because screen readers can recognize that a header contains labels. (Note that you must set a 
header row or column to provide such accessibility. It is not sufficient to use bold or centered text.) 

To insert a table: 

1. Open a document in Dreamweaver. 

2. Place the insertion point in your document where you 
want the table to appear. 

3. Select the Layout category in the Insert bar. 

 Make sure the Standard mode button is selected 
(Figure 1). 

4. Click the Table button on the Insert bar. 

 The Table dialog box opens (Figure 2). 

5. Enter the number of rows and columns. 

6. Make changes to any of the options in the dialog box. 
For information about the options, click the Help button 
in the dialog box. 

 Applying a column header or row header in particular 
can improve the accessibility of a data table. The 
browser will display these headers slightly differently, 
and such headers are read by screen readers. 

To set a header row or column: 

7. Select one of the options in the Header section. 

 For example, if you create a table that lists a collection 
of books, with columns labeled Author, Title, and Year, 
you should set the top row as a header. By default, 
header rows or columns are bolded and centered 
(Figure 3). Screen readers can now read this header. 

8. Click OK. 

 The table appears in your document. 

Figure 1 Layout category in the Insert bar with 
Standard mode selected 

 

Figure 2 Table dialog box 

 

 
Figure 3 Table with top row set as header 
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Selecting table elements 
You can select an entire table, a row, or a column, or you can select a contiguous block of cells within a table. After 
you’ve selected a table or cells, you can modify the appearance of the selection or of the text contained in the 
selection. 

To select an entire table: 

Do one of the following: 

• Click the upper left corner of the table or click 
anywhere on the bottom edge. 

• Click in a table cell, and then select 
Modify > Table > Select Table. 

 Selection handles appear on the selected table’s lower 
and right edges (Figure 4). 

To select rows or columns: 

1. Position the pointer to point at the left edge of a row or 
the top edge of a column. 

2. When the pointer changes to a selection arrow, click to 
select the row or column, or drag to select multiple rows 
or columns (Figure 5). 

To select a single cell: 

Do one of the following: 

• Click in the cell. Then drag to select the cell. 

• Click in the cell. Then select Edit > Select All. 

 
Figure 4 Selection handles on a selected table 

 

 
Figure 5 A selected column in a table 
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Adding rows and columns 
You can add a single row or column, or you can add multiple rows or columns at the same time. 

To add a row: 

1. Place the insertion point in a table cell, or select an 
entire row. 

2. Do one of the following: 

• Click the Insert Row Above button or the 
Insert Row Below button (Figure 6). 

• Select Insert > Table Objects > Insert Row Above 
or Insert > Table Objects > Insert Row Below. 

 A new row appears above or below the insertion point or 
the selected row. 

To add a column: 

1. Place the insertion point in a table cell, or select an 
entire column. 

2. Do one of the following: 

• Click the Insert Column To The Left button or the 
Insert Column To The Right button (Figure 5). 

• Select Insert > Table Objects > 
Insert Column To The Left or select Insert > 
Table Objects > Insert Column To The Right. 

 A new row appears above or below the insertion point or 
the selected row. 

 

 

Figure 6 Layout Insert bar 

 

Deleting rows and columns 
You can delete a single row or column, or you can delete multiple rows or columns at the same time. 

To delete rows or columns from a table: 

1. Select one or more rows or columns. 

2. Press Delete or Backspace. 

To remove cell contents, but leave the cells intact: 

1. Select one or more cells. 

2. Select Edit > Clear or press Delete. 

 Note: If you select an entire row or column, and then 
select Edit > Clear or press Delete, Dreamweaver 
removes the entire row or column—not just their 
contents—from the table. 

 

 

Insert Row 
buttons 

Insert Column 
buttons 
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Resizing tables, rows, and columns 
You can resize an entire table or individual rows and columns. When you resize an entire table, all the cells in the 
table resize proportionately. 

To resize a table: 

Select the table and do one of the following. 

• To resize the table horizontally, drag the selection 
handle in the right. 

• To resize the table vertically, drag the selection 
handle in the bottom. 

• To resize in both dimensions, drag the selection 
handle at the lower right corner. 

To resize a column’s width: 

Do one of the following: 

• Drag the right border of the column. 

• Select the column. In the Property inspector 
(Figure 7), change the number in the Column 
Width text box. 

To resize a row’s height: 

Do one of the following: 

• Drag the lower border of the row. 

• Select the row. In the Property inspector (Figure 7), 
change the number in the Row Height text box. 

Figure 7 Table Property inspector 
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Modifying table properties 
You can modify the properties of a table, its rows and columns, or its cells by using the Property inspector. Attention 
to table borders and cell padding (the amount of spacing between table cells) in particular can help you create 
effective table designs. 

You can also set a row or column as a header by using the Property inspector. Headers help make tables more useful 
and accessible. 

To modify table properties: 

1. Select the table you want to modify. 

 Make sure the Property inspector is open (Figure 8). In 
Windows, it is docked at the bottom of the screen. If the 
Property inspector is not open, select Window > 
Properties. 

2. Make changes to any of the options in the Property 
inspector (Figure 8). 

To modify table row or column properties: 

1. Select the row or column you want to modify. 

2. Make changes to any of the options in the Property 
inspector. 

To modify table cell properties: 

1. In your document, select the cell or cells you want to 
modify. 

2. Make changes to any of the options in the Property 
inspector. 

To set a row or a column as header: 

1. Select a row or column. 

2. In the Property inspector, select the Header option. 

 The words in the row or column will appear centered 
and bolded (Figure 9). 

Figure 8 Table Property inspector 

 

 
Figure 9 Table with top row set as header 
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The Dreamweaver Insert bar 
Student name: _________________________________________________ Date:________________________ 

In Adobe Dreamweaver CS3, the Insert bar contains buttons for inserting various types of objects, such as images 
and tables, into a document (web page). The Insert bar contains several categories, such as Common and Layout. 

Identify the buttons on the Common category in the Insert bar. 

 

 

 
 

 

 

 

 

 

 

 

 

 

Identify the buttons on the Layout category in the Insert bar. 
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Describe the contents of the other categories of the Insert bar. 

Forms category: _______________________________________________________________________________ 

____________________________________________________________________________________________ 

Data category:_________________________________________________________________________________ 

____________________________________________________________________________________________ 

Spry category:_________________________________________________________________________________ 

____________________________________________________________________________________________ 

Text category:_________________________________________________________________________________ 

____________________________________________________________________________________________ 

Favorites category: _____________________________________________________________________________ 

____________________________________________________________________________________________ 

 

 

On the Insert bar below, indicate where you can switch back and forth between categories: 

 
 

 

 

How do you switch between Show As Menu and Show As Tabs? _________________________________________ 

____________________________________________________________________________________________ 

____________________________________________________________________________________________ 

____________________________________________________________________________________________ 



Adobe Dreamweaver CS3 Activity 2.1 guide 

© 2007 Adobe Systems Incorporated The Dreamweaver Insert bar 1 

The Dreamweaver Insert bar 
In Adobe Dreamweaver CS3, the Insert bar contains buttons for inserting various types of objects, such as images 
and tables, into a web page. 

You can use the Insert bar to create or insert content in seven categories: 

• The Common category contains buttons for inserting the most commonly used objects, such as links, images, 
and tables. 

• The Layout category gives you options to insert tables, div tags, layers, and frames. You can view tables in 
either Standard (default) mode or Expanded Tables mode.  

• The Forms category contains buttons for creating forms and inserting form elements. 

• The Data category lets you insert dynamic elements such as recordsets, repeated regions, and record insertion 
and update forms. 

• The Spry category lets you insert “widgets” that display data from other files and various interface elements 
(such as navigation bars and menus) that rely on JavaScript and CSS. (Spry widgets are not covered in this 
study, but you can read find out more about them in Dreamweaver Help (select Help > Dreamweaver Help and 
look for the section called “Building Spry pages visually.”) 

• The Text category is used for working in Code view and enables you to insert a variety of text- and list-
formatting tags, such as b, em, p, h1, and ul. 

• Use the Favorites category to customize a list of Insert bar buttons for fast access. You can customize this 
category by right-clicking (Windows) or Control-clicking (Mac OS) the Insert bar. 

The Insert bar menu 
You switch between these categories by using the Insert bar menu, which is located on the left side of the Insert bar 
(Figure 1). 

 
Figure 1 Insert bar menu 

You can also view the Insert bar categories as tabs (Figure 2). 

In the Insert bar menu, select Show As Tabs to switch to tabs view. 

 
Figure 2 Insert bar in tabs view 

To return to menu view, select Show As Menu in the context menu on the right side of the Insert bar. 




